Note that Ledger have released a new app that is not compatible with ElectrumSV. Update at your own risk. You chose to buy and use their devices, and I have been lamenting the increasing incompatibility for years so this has not been without warning.

Additionally, the Electrum wallet for Bitcoin Core is apparently not compatible with this updated app either. So this is not just a Bitcoin SV thing.

P.S. I am on vacation until the 2nd of January.

--

--